Datalogger usage

Discussion about Data2KML and other open-source telematics utilities developed by us
ChrisF
Posts: 5
Joined: Wed Oct 12, 2016 2:39 am

Datalogger usage

Postby ChrisF » Wed Oct 12, 2016 2:44 am

Hi All, I'm new to Freematics and Audrino and just had a question on getting going. I just received my Freematics ONE a couple days ago, compiled and uploaded the newest datalogger sketch without issue. Inserted a FAT formatted sd card and proceed to attach it to my truck for testing. Everything looks great but where I pull the SD card after a trip it has no data on it. Is there something I'm missing about config?

mikebolt
Posts: 19
Joined: Sat Sep 24, 2016 3:12 am

Re: Datalogger usage

Postby mikebolt » Wed Oct 12, 2016 3:53 am

This is a known issue. See this post: viewtopic.php?f=2&t=1885

Do you get a DATA directory with some empty files in it?

ChrisF
Posts: 5
Joined: Wed Oct 12, 2016 2:39 am

Re: Datalogger usage

Postby ChrisF » Wed Oct 12, 2016 6:59 am

I think my issue may be a little big different. I'm not seeing empty files, I'm simply seeing nothing. The card is completely empty. I'm using a lexar 32G microSD card. Starting to wonder if it could be a compatibility issue?

mikebolt
Posts: 19
Joined: Sat Sep 24, 2016 3:12 am

Re: Datalogger usage

Postby mikebolt » Wed Oct 12, 2016 9:41 am

You could try using the SdFat library instead of the SD library. SdFat is just a newer version of that library, and they might have fixed a bug that is causing your problem. I got SdFat working with the gptest sketch. I also got it working with the datalogger sketch, but I have modified it beyond the point of contributing the changes without lots of extra effort.

I would try to make a new sketch that simply logs some text to a file on the SD card to help pinpoint the issue. You might want to order a new SD card as well.

ChrisF
Posts: 5
Joined: Wed Oct 12, 2016 2:39 am

Re: Datalogger usage

Postby ChrisF » Fri Oct 14, 2016 1:03 am

Got it! Was definitely an SD incompatibility. Switched out to a different card and started working like a charm.


Return to “Freematics Software”

Who is online

Users browsing this forum: No registered users and 1 guest