Search found 5 matches

by xWaspAx
Mon Sep 20, 2021 6:26 pm
Forum: Freematics Software
Topic: Is it possible to send CAN messages?
Replies: 0
Views: 2651

Is it possible to send CAN messages?

Hi, I am wondering if it is possible to send CAN messages using Freematics one+ model A. I would like to send a message before starting sniffing CAN, to dodge the SGW control unit, which is a safety measure that is keeping me away from sniffing CAN. I have the message ID and signal value to send, is...
by xWaspAx
Thu Jul 08, 2021 12:25 am
Forum: Freematics Products
Topic: ONE+ Model A external sensors
Replies: 2
Views: 892

Re: ONE+ Model A external sensors

Yes, I am indeed working with Arduino framework and this is the first thing I've tried. It doesn't work. I am powering the Freematics via USB cable because I don't have a vehicle available right now, could be this the issue? I am also not able to use the VCC pin to directly power a LED for example. ...
by xWaspAx
Wed Jul 07, 2021 7:57 pm
Forum: Freematics Products
Topic: ONE+ Model A external sensors
Replies: 2
Views: 892

ONE+ Model A external sensors

Hi, I have the Freematics ONE+ Model A and I am trying without success to use GPIO 32/33 via molex enclosure purchased on the site. How do I declare those pins in the code to work as digital output? Is it necessary to power the module via OBD port in order to use the VCC 5V pin? If somebody can plea...
by xWaspAx
Sat May 22, 2021 12:55 am
Forum: Freematics Software
Topic: mpu9250_dmp_quaternion - 'Type Error'
Replies: 2
Views: 5171

Re: mpu9250_dmp_quaternion - 'Type Error'

Hi, I am getting the same compiling error as you, have you found by any chance a solution to this issue?
by xWaspAx
Sat May 22, 2021 12:36 am
Forum: Freematics Software
Topic: mpu9250_dmp_quaternion.ino not working - FREEMATICS ONE+ Model A
Replies: 0
Views: 3676

mpu9250_dmp_quaternion.ino not working - FREEMATICS ONE+ Model A

Hy guys, I am new to this forum and I apologize if my form is not correct. I've just received the Freematics ONE+ Model A OBD dongle and I am trying to test the onboard 9 axes IMU. I am using Arduino IDE (v 1.8.13) in order to program the ESP32 mcu of the device. I've manually installed the library ...