Search found 22 matches

by daveywatt
Thu Jul 16, 2020 4:45 pm
Forum: Freematics Software
Topic: Did anyone manage to make freematics One+ send data to NodeJs server via HTTP POST
Replies: 4
Views: 4248

Re: Did anyone manage to make freematics One+ send data to NodeJs server via HTTP POST

Did you guys ever get this working? I am seeing HTTP issues over SIM7600 but over WiFi its fine.
by daveywatt
Thu Jul 16, 2020 12:30 pm
Forum: Freematics Software
Topic: Issues sending data via HTTP(s) using Freematics telelogger
Replies: 8
Views: 2562

Re: Issues sending data via HTTP(s) using Freematics telelogger

Confirming this is still not working. I suspect either an issue with the Freematics software or I have a SIM module hardware issue. I have tried the following steps, both via a USB-C to MicroUSB serial connection that is supplies up to 2A power and via two seperate car OBD2 ports. 1. Cloned the late...
by daveywatt
Wed Jul 15, 2020 9:51 am
Forum: Freematics Software
Topic: Issues sending data via HTTP(s) using Freematics telelogger
Replies: 8
Views: 2562

Re: Issues sending data via HTTP(s) using Freematics telelogger

I have attempted this on a 5v/2A output and via a car OBD2 port. If it helps, the cell connection works fine on stock telelogger.ino software with cell APN set to "telstra.iph" (Telstra SIM) and sim pin specified with PROTOCOL_UDP set. This is to hub.freematics.com. The hub confirms my connection (s...
by daveywatt
Tue Jul 14, 2020 8:35 pm
Forum: Freematics Software
Topic: Issues sending data via HTTP(s) using Freematics telelogger
Replies: 8
Views: 2562

Re: Issues sending data via HTTP(s) using Freematics telelogger

Thanks. Is there a pin diagram available so I can supply 12v power while still testing via USB?
by daveywatt
Mon Jul 13, 2020 10:55 pm
Forum: Freematics Software
Topic: Issues sending data via HTTP(s) using Freematics telelogger
Replies: 8
Views: 2562

Re: Issues sending data via HTTP(s) using Freematics telelogger

Here is the output from sim5360test.ino. Same issue it seems. Its worth noting that I have attempted this connect/send on both the hub.freematics.com:443 endpoint and my own server running HTTPS. SIM7600E OK IMEI:XXXXXXXXXXX SIM Card OK Registering on network...OK Operator:Telstra #StaySafe Telstra ...
by daveywatt
Mon Jul 13, 2020 10:50 pm
Forum: Freematics Software
Topic: Issues sending data via HTTP(s) using Freematics telelogger
Replies: 8
Views: 2562

Re: Issues sending data via HTTP(s) using Freematics telelogger

I can confirm that any HTTP requests seem to fail.. Here is the output from a Freematics One + with the sim7600test.ino software: SIM7600E OK IMEI:XXXXXXXXXXX SIM Card OK Registering on network...OK Operator:Telstra #StaySafe Telstra Obtaining IP address...10.147.174.51 Init HTTPS stack...NO Connect...
by daveywatt
Mon Jul 13, 2020 10:48 am
Forum: Freematics Software
Topic: Freematics One + not connecting via NET_SIM7600
Replies: 2
Views: 857

Re: Freematics One + not connecting via NET_SIM7600

This has been resolved.

Not sure what the issue was, but setting the config back to NET_WIFI and then reverting to NET_SIM7600 seems to have fixed it.

Could of been a strange SIM related issue...
by daveywatt
Mon Jul 13, 2020 9:30 am
Forum: Freematics Software
Topic: Freematics One + not connecting via NET_SIM7600
Replies: 2
Views: 857

Freematics One + not connecting via NET_SIM7600

I have purchased a new Telstra data SIM which has since been activated, however my Freematics One + won't establish a connection no matter what settings I try... The sim is on a data only plan, and I have set the following: #define NET_DEVICE NET_SIM7600 #define CELL_APN "telstra.iph" #define SIM_CA...
by daveywatt
Sun Jul 12, 2020 6:15 pm
Forum: Freematics Software
Topic: Issues sending data via HTTP(s) using Freematics telelogger
Replies: 8
Views: 2562

Issues sending data via HTTP(s) using Freematics telelogger

I've been trying to get a simple HTTP post event sent from a FreematicsPlus device. Sending via UDP is fine, but as soon as I set #define SERVER_PROTOCOL PROTOCOL_HTTPS I get the following errors and an infinite reboot. I have not changed any other code, other than setting #define SERVER_HOST to my ...
by daveywatt
Thu Jul 02, 2020 11:16 am
Forum: Freematics Products
Topic: Recommendations on product for getting started
Replies: 6
Views: 2000

Re: Recommendations on product for getting started

Thanks for your help mate. I just ordered this setup without the cellular GPS module.

Looking forward to building something fun!