Sim7600test SIM not inserted

Inquiry and support for Freematics products
Post Reply
fresh1130
Posts: 2
Joined: Mon Mar 29, 2021 8:21 pm

Sim7600test SIM not inserted

Post by fresh1130 »

I have Freematics ONE+ Model B with cellular module "SIMCOM_SIM7600E-H" as well as the hologram global SIM.
When I run the sim7600test, I get the SIM not inserted response.
I use the code with the following information.

Code: Select all

git commit : 3cab13d | 2021-03-16 | Stanley Huang | Deprecated
Arduino 1.8.13
I also enabled

Code: Select all

$ git diff ../../libraries/FreematicsPlus/FreematicsPlus.cpp
diff --git a/libraries/FreematicsPlus/FreematicsPlus.cpp b/libraries/FreematicsPlus/FreematicsPlus.cpp
index c3e98ef..97f54fd 100644
--- a/libraries/FreematicsPlus/FreematicsPlus.cpp
+++ b/libraries/FreematicsPlus/FreematicsPlus.cpp
@@ -26,7 +26,7 @@
 #include "FreematicsGPS.h"

 #define VERBOSE_LINK 0
-#define VERBOSE_XBEE 0
+#define VERBOSE_XBEE 1

 static TinyGPS gps;
 static bool gpsHasDecodedData = false;
Below is my log

Code: Select all

ets Jun  8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:1216
ho 0 tail 12 room 4
load:0x40078000,len:9720
ho 0 tail 12 room 4
load:0x40080400,len:6352
entry 0x400806b8
Bee Rx:35 Tx:2
Init cellular module...xBee power pin set to low
xBee power pin set to high
=== SENT@5671 ===
AT
==================
=== SENT@6671 ===
AT
==================
=== SENT@7671 ===
AT
==================
=== SENT@8671 ===
AT
==================
=== SENT@9671 ===
AT
==================
xBee power pin set to low
xBee power pin set to high
=== SENT@14881 ===
AT
==================
=== RECV@14881 ===

+CME ERROR: SIM not inserted
==================
=== RECV@14884 ===
AT
OK
==================
=== SENT@14885 ===
ATE0
==================
=== RECV@14889 ===
ATE0
OK
==================
=== SENT@14893 ===
ATI
==================
=== RECV@14907 ===

Manufacturer: SIMCOM INCORPORATED
Model: SIMCOM_SIM7600E-H
Revision: SIM7600M22_V1.1
IMEI: 867584033642930
+GCAP: ==================
=== RECV@14911 ===
+CGSM

OK
==================
SIM7600E-H OK
IMEI:867584033642930
=== SENT@14919 ===
AT+CPIN?
==================
=== RECV@14924 ===

+CME ERROR: SIM not inserted
==================
=== SENT@15429 ===
AT+CPIN?
==================
=== RECV@15434 ===

+CME ERROR: SIM not inserted
==================
=== SENT@15934 ===
AT+CPIN?
==================
=== RECV@15939 ===

+CME ERROR: SIM not inserted
==================
=== SENT@16439 ===
AT+CPIN?
==================
=== RECV@16444 ===

+CME ERROR: SIM not inserted
==================
=== SENT@16944 ===
AT+CPIN?
==================
=== RECV@16949 ===

+CME ERROR: SIM not inserted
==================
=== SENT@17449 ===
AT+CPIN?
==================
=== RECV@17454 ===

+CME ERROR: SIM not inserted
==================
=== SENT@17954 ===
AT+CPIN?
==================
=== RECV@17959 ===

+CME ERROR: SIM not inserted
==================
=== SENT@18459 ===
AT+CPIN?
==================
=== RECV@18464 ===

+CME ERROR: SIM not inserted
==================
=== SENT@18964 ===
AT+CPIN?
==================
=== RECV@18969 ===

+CME ERROR: SIM not inserted
==================
=== SENT@19469 ===
AT+CPIN?
==================
=== RECV@19474 ===

+CME ERROR: SIM not inserted
==================
No SIM Card
Registering on network...=== SENT@19974 ===
AT+CPSI?
==================
=== RECV@19979 ===

+CPSI: NO SERVICE,Online

OK
==================
=== SENT@19980 ===
AT+CPSI?
==================
=== RECV@19985 ===

+CPSI: NO SERVICE,Online

OK
I am stucked on the sim insertion problem.
Can anyone give me some help on this?
Thanks in advance.

fresh1130
Posts: 2
Joined: Mon Mar 29, 2021 8:21 pm

Re: Sim7600test SIM not inserted

Post by fresh1130 »

Hi Stanly,

I update the code to the latest and use the telelogger.
I still get "SIM not inserted" error.
I can debug the AT command but I need help with this problem.

Code: Select all

a42b6ab | 2021-04-23 | Stanley Huang | Update FreematicsPlus.cpp
After enable verbose log

Code: Select all

$ git diff
diff --git a/libraries/FreematicsPlus/FreematicsPlus.cpp b/libraries/FreematicsPlus/FreematicsPlus.cpp
index 1d033ac..af05c5e 100644
--- a/libraries/FreematicsPlus/FreematicsPlus.cpp
+++ b/libraries/FreematicsPlus/FreematicsPlus.cpp
@@ -25,8 +25,8 @@
 #include "FreematicsPlus.h"
 #include "FreematicsGPS.h"

-#define VERBOSE_LINK 0
-#define VERBOSE_XBEE 0
+#define VERBOSE_LINK 1
+#define VERBOSE_XBEE 1

 static TinyGPS gps;
 static bool gpsHasDecodedData = false;
The verbose log

Code: Select all

ets Jun  8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:1216
ho 0 tail 12 room 4
load:0x40078000,len:9720
ho 0 tail 12 room 4
load:0x40080400,len:6352
entry 0x400806b8
E (189) spiram: SPI RAM not initialized
E (189) esp_himem: Cannot allocate memory for meta info. Not initializing!
CPU:240MHz FLASH:4MB
IRAM:358KB PSRAM:8191KB
DEVICE ID:A0HN8G3J
[UART BEGIN]
[UART SEND]ATBR1 7D000
ÿUART RECV]OK
[UART END]
[UART BEGIN]
[UART SEND]ATI
>UART RECV]OBD2USART V1.4
Bee Rx:35 Tx:2
TYPE:14
MEMS:ICM-20948
xBee power pin set to low
ACC BIAS:-0.05/-0.01/-1.02
[UART SEND]ATGPSON
xBee power pin set to high
[UART RECV]/
[UART SEND]ATGRR
>UART RECV]OK
[UART SEND]ATGRR
[UART RECV]>
[UART SEND]ATGRR
>UART RECV]$GNTXT,01,01,02,u-blox AG - www.u-blox.com*4E
GNSS:OK
[UART SEND]ATZ
>UART RECV]ELM327 v1.5
[UART SEND]ATE0
>UART RECV]OK
[UART SEND]ATH0
>UART RECV]OK
[UART SEND]010D
=== SENT@6252 ===
AT
==================
>UART RECV]UNABLE TO CONNECT
[UART SEND]010D
=== SENT@7252 ===
AT
==================
=== SENT@8252 ===
AT
==================
>UART RECV]UNABLE TO CONNECT
OBD:NO
=== SENT@9252 ===
AT
==================
SD:7533 MB total, 2 MB used
/DATA/1.CSV
File: /DATA/2.CSV
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
[BUF] 3 samples | 26 bytes | 3%
=== SENT@10252 ===
AT
==================
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
xBee power pin set to low
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
xBee power pin set to high
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
[BUF] 11 samples | 98 bytes | 12%
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
=== SENT@15461 ===
AT
==================
=== RECV@15461 ===

RDY
==================
=== RECV@15464 ===
AT
OK
==================
=== SENT@15465 ===
ATE0
==================
15468 ===D]=== RECV@ATGPS

==================
=== RECV@[UART RECV]15473 ===$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>

OK
==================

=== SENT@15482 ===
ATI
==================
=== RECV@15495 ===

Manufacturer: SIMCOM INCORPORATED
Model: SIMCOM_SIM7600E-H
Revision: SIM7600M22_V1.1
IMEI: 867584033654943
+GCAP: ==================
=== RECV@15499 ===
+CGSM

OK
==================
CELL:SIM7600E-H
=== SENT@15505 ===
AT+CPIN?
==================
=== RECV@15511 ===

+CME ERROR: SIM not inserted
==================
=== RECV@15760 ===

+CME ERROR: SIM not inserted
==================
=== SENT@16010 ===
AT+CPIN?
==================
=== RECV@16016 ===

+CME ERROR: SIM not inserted
==================
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
[BUF] 23 samples | 202 bytes | 25%
=== SENT@16516 ===
AT+CPIN?
==================
=== RECV@16521 ===

+CME ERROR: SIM not inserted
==================
=== SENT@17021 ===
AT+CPIN?
==================
=== RECV@17026 ===

+CME ERROR: SIM not inserted
==================
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
=== SENT@17526 ===
AT+CPIN?
==================
=== RECV@17531 ===

+CME ERROR: SIM not inserted
==================
=== SENT@18031 ===
AT+CPIN?
==================
=== RECV@18036 ===

+CME ERROR: SIM not inserted
==================
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
=== SENT@18536 ===
AT+CPIN?
==================
=== RECV@18541 ===

+CME ERROR: SIM not inserted
==================
=== SENT@19041 ===
AT+CPIN?
==================
=== RECV@19046 ===

+CME ERROR: SIM not inserted
==================
[UART SEND]ATGPS
[UART RECV]$GNIFO,000000,00000000,0,0,0,0,0,0,9999*C7
>
=== SENT@19546 ===
AT+CPIN?
==================
=== RECV@19551 ===

+CME ERROR: SIM not inserted
==================

stanley
Site Admin
Posts: 842
Joined: Sat Mar 01, 2014 3:15 am

Re: Sim7600test SIM not inserted

Post by stanley »

Thanks for letting me know by email that you have inserted the SIM card in wrong direction.

Post Reply