Board keeps restarting

Inquiry and support for Freematics products
Post Reply
osmosis311
Posts: 3
Joined: Tue Apr 20, 2021 6:11 am

Board keeps restarting

Post by osmosis311 »

Hi,

I just got the Model H, and when I upload the telelogger sketch, sometimes it works, but other times, the device goes into an endless crash/reboot loop. Logs below.

Any advice?

Thanks!

----

E (192) spiram: SPI RAM not initialized
E (192) esp_himem: Cannot allocate memory for meta info. Not initializing!
CPU:240MHz FLASH:16MB
IRAM:376KB PSRAM:8191KB
DEVICE ID:A0HLZ8HK
MEMS:ICM-20948
ACC BIAS:0.02/-0.01/0.99
GNSS:NO
OBD:NO
NO SD CARD
Guru Meditation Error: Core 1 panic'ed (LoadProhibited). Exception was unhandled.
Core 1 register dump:
PC : 0x400e083c PS : 0x00060d30 A0 : 0x800dbcbe A1 : 0x3ffb1ee0
A2 : 0x3ffbee24 A3 : 0x3ffc10e8 A4 : 0x00000005 A5 : 0x00000020
A6 : 0x00000020 A7 : 0x3ffc1320 A8 : 0x10624dd3 A9 : 0x400fff3c
A10 : 0x00000000 A11 : 0x00000000 A12 : 0x00000002 A13 : 0x0000ff00
A14 : 0x00ff0000 A15 : 0xff000000 SAR : 0x0000001c EXCCAUSE: 0x0000001c
EXCVADDR: 0x00000000 LBEG : 0x400dbbe6 LEND : 0x400dbbf0 LCOUNT : 0x0000001e

Backtrace: 0x400e083c:0x3ffb1ee0 0x400dbcbb:0x3ffb1f20 0x400dc8f5:0x3ffb1f80 0x400dd6b5:0x3ffb1fb0 0x4008affd:0x3ffb1fd0

Rebooting...
ets Jun 8 2016 00:22:57

rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:928
ho 0 tail 12 room 4
load:0x40078000,len:9280
load:0x40080400,len:5860
entry 0x40080698
E (192) spiram: SPI RAM not initialized
E (192) esp_himem: Cannot allocate memory for meta info. Not initializing!
CPU:240MHz FLASH:16MB
IRAM:376KB PSRAM:8191KB
DEVICE ID:A0HLZ8HK
MEMS:ICM-20948
ACC BIAS:0.02/-0.01/0.99
GNSS:NO
OBD:NO
NO SD CARD
Guru Meditation Error: Core 1 panic'ed (LoadProhibited). Exception was unhandled.
Core 1 register dump:
PC : 0x400e083c PS : 0x00060d30 A0 : 0x800dbcbe A1 : 0x3ffb1ee0
A2 : 0x3ffbee24 A3 : 0x3ffc10e8 A4 : 0x0000000a A5 : 0x000f4240
A6 : 0x3f4047d0 A7 : 0x3ffc1320 A8 : 0x00060023 A9 : 0x400fff3c
A10 : 0x00000000 A11 : 0x00000000 A12 : 0x8008b210 A13 : 0x3ffb1e00
A14 : 0x00000000 A15 : 0x3ffb0060 SAR : 0x0000001c EXCCAUSE: 0x0000001c
EXCVADDR: 0x00000000 LBEG : 0x400dbbe6 LEND : 0x400dbbf0 LCOUNT : 0x0000001e

Backtrace: 0x400e083c:0x3ffb1ee0 0x400dbcbb:0x3ffb1f20 0x400dc8f5:0x3ffb1f80 0x400dd6b5:0x3ffb1fb0 0x4008affd:0x3ffb1fd0

Rebooting...
ets Jun 8 2016 00:22:57
stanley
Site Admin
Posts: 853
Joined: Sat Mar 01, 2014 3:15 am

Re: Board keeps restarting

Post by stanley »

It seems your library code might be outdated. It is also possible your USB port might not supply enough power surge. In this case, try connecting the device to OBD port (powered from OBD) or use 80Mhz CPU clock.
Post Reply