Freematics Emulator signal only when OBDLink EX attached

Inquiry and support for Freematics products
Post Reply
Jeffrey Urban
Posts: 3
Joined: Wed May 05, 2021 7:00 am

Freematics Emulator signal only when OBDLink EX attached

Post by Jeffrey Urban »

Hi Freematics,

I've found that my Freematics Emulator has no detectable signal on CAN, unless it is connected to an OBDLink EX, and then only when the OBDLink EX is in 'connected' mode with its OBDWiz GUI application. When this is the case, I measure 20mV between CAN_H and CAN_L, and can read CAN traffic on a connected Macchina P1. I'm using the Macchina OBD3WAY to connect devices and tap out pins for measurement.

When the Freematics Emulator is not connected to a dongle, or when connected to other dongles besides the OBDLink EX, or when connected to the OBDLink EX but without placing the OBDLink EX in the 'connected' state, there is no detectable voltage differential from CAN_H to CAN_L, and no CAN messages read on the Macchina P1.

I don't have a scope or logic analyzer handy to look at the signal. Can you suggest other troubleshooting steps to confirm if the Freematics Emulator is driving the CAN signal correctly?

Thanks,
Jeffrey
stanley
Site Admin
Posts: 853
Joined: Sat Mar 01, 2014 3:15 am

Re: Freematics Emulator signal only when OBDLink EX attached

Post by stanley »

The emulator does not actively generate any signal without a OBD device connected.
Jeffrey Urban
Posts: 3
Joined: Wed May 05, 2021 7:00 am

Re: Freematics Emulator signal only when OBDLink EX attached

Post by Jeffrey Urban »

My Freematics Emulator doesn't generate any signal when any of several off-the-shelf OBD dongles are connected.

I found one OBD dongle for which it does generate signal, which is the OBDLink EX (when in the connected mode, per its OBDWiz GUI).

Can you clarify what electrical characteristic or behavior is necessary from the attached OBD device so that the Freematics Emulator will generate a signal. That way I will know how to artificially add whatever the Freematics Emulator is looking for, which is not present in any of the other OBD dongles.
Last edited by Jeffrey Urban on Fri May 07, 2021 5:05 am, edited 1 time in total.
Jeffrey Urban
Posts: 3
Joined: Wed May 05, 2021 7:00 am

Re: Freematics Emulator signal only when OBDLink EX attached

Post by Jeffrey Urban »

It is only when connected to an OBD diagnostic scanner that is actively scanning, and not when connected to an OBD monitoring device that the Freematics Emulator generates a CAN signal. This is not realistic for most cars, where we should expect to see signal activity on CAN when passively listening, and not actively scanning.

It seems the problem is a mismatch in how the Freematics Emulator is marketed versus what it actually does.

The Freematics Emulator is marketed as simulating a CAN bus and emulating a car:
  • "CAN bus simulation"
  • "as if a real car"
  • "port identical to that of a real car"
  • "Your OBD-II device should then work as if plugged in the OBD-II port of a real car."
https://freematics.com/products/freemat ... lator-mk2/

But what I've found is that it neither simulates a CAN bus nor emulates a car. Instead, it emulates a lone ECU; and it appears to be limited to emulating those ECUs that only respond to CAN requests, but do not broadcast any signals on their own.

Please clarify if I am mistaken. It seems like a good product, just not what I was expecting based on the description.
Last edited by Jeffrey Urban on Fri May 07, 2021 11:18 pm, edited 1 time in total.
stanley
Site Admin
Posts: 853
Joined: Sat Mar 01, 2014 3:15 am

Re: Freematics Emulator signal only when OBDLink EX attached

Post by stanley »

Some OBD device checks voltage and only start working when voltage jumps as in the case when ignition started. However emulator's output voltage is fixed unless you use a voltage adjustable power supply.
Jeffrey Urban
Posts: 3
Joined: Wed May 05, 2021 7:00 am

Re: Freematics Emulator signal only when OBDLink EX attached

Post by Jeffrey Urban »

The voltage supply detail is useful information, but not relevant to my other feedback / questions, which remain pending moderator approval. I also had previously sent private messages and have received no response.
Post Reply