Possible reason for ONE+ (H) to stop sending data

Inquiry and support for Freematics products
Post Reply
wahlau
Posts: 3
Joined: Mon Aug 02, 2021 1:59 pm

Possible reason for ONE+ (H) to stop sending data

Post by wahlau »

Hi all,

I have an unit of ONE+ (H model) and installed with the latest version of telelogger from git. I followed the instructions including recompiling the libraries this week, and left it on OBD port of a vehicle - it worked pretty ok for the first few hours, then it just remain "silent" with the following std. output (from teleserver, not from the console of the unit):

Code: Select all

Reply sent:1#EV=7,RX=82,TX=82*5F
42 bytes from 13.121.10.224| [1] #83 3425 bytes | Samples:0 | Device Tick:3745705
Ping received
Reply sent:1#EV=7,RX=83,TX=83*61
42 bytes from 13.121.10.224 | [1] #84 3467 bytes | Samples:0 | Device Tick:3745705
Ping received
Reply sent:1#EV=7,RX=84,TX=84*63
42 bytes from 13.121.10.224| [1] #85 3509 bytes | Samples:0 | Device Tick:3745705
Ping received
Reply sent:1#EV=7,RX=85,TX=85*65
42 bytes from 13.121.10.224 | [1] #86 3551 bytes | Samples:0 | Device Tick:3745705
Ping received
What could possibly make the unit stop sending any updates, or could the unit "hang" and requires a "hard reset"? Anyone with experience please help thanks.
SamyAbi
Posts: 10
Joined: Wed May 19, 2021 2:43 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by SamyAbi »

Hi Wahlau,

I'm having the same issue with the Freematics One+ (B).

My case it happens when the car is being turned off (really hard to replicate it, it happens randomly).

The device seems to hang and the LED remains blue. Meanwhile, every other time the device is blinking unless it goes into standby mode in which the LED turns off. My guess is it has something to do with the device suddenly receiving a lower voltage in the middle of sending data. I am doing some digging to see how I can counteract this but still no luck yet.

Hopefully Stanley or someone else may be able to shed some more light on this.
wahlau
Posts: 3
Joined: Mon Aug 02, 2021 1:59 pm

Re: Possible reason for ONE+ (H) to stop sending data

Post by wahlau »

Hi Samy,

nice to get some feedback from you - I have reflashed the unit yesterday using a lower clock rate (160Mhz) - surprise surprise - it looks like it does not "hang" anymore. Will continue to monitor and see whether if the unit will work continuously without hiccup.

Update: 19/9/2021 - the same hiccup/hang happened again yesterday. Now I see periodical ping but no more data update. To the Freematics Hub it seems the unit/vehicle is parked since Friday evening while I am sure Saturday the vehicle is traveling. Thought it could be heat issue but this round, with lower clock it just ran just nice for 5 days until the same problem occurs again.
stanley
Site Admin
Posts: 932
Joined: Sat Mar 01, 2014 3:15 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by stanley »

Have you enabled RESET_AFTER_WAKEUP in config.h?
wahlau
Posts: 3
Joined: Mon Aug 02, 2021 1:59 pm

Re: Possible reason for ONE+ (H) to stop sending data

Post by wahlau »

Hi Stanley,

I didn't change anything in config.h so the default value is there:

Code: Select all

#define RESET_AFTER_WAKEUP 1
it should be kept that way, right?
SamyAbi
Posts: 10
Joined: Wed May 19, 2021 2:43 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by SamyAbi »

Hey Stanley,

I actually disabled the RESET_AFTER_WAKEUP, should I re-enable it? I felt as though it was getting hung up when RESET_AFTER_WAKEUP was on.
stanley
Site Admin
Posts: 932
Joined: Sat Mar 01, 2014 3:15 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by stanley »

Please enable RESET_AFTER_WAKEUP in case there is lockup issue.
SamyAbi
Posts: 10
Joined: Wed May 19, 2021 2:43 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by SamyAbi »

Hey Stanley,

Enabled the reset, device hung up after 2 drives. Any idea as to why? Everything else in the code is basically the same, just removed some PID's and added fuel level.
stanley
Site Admin
Posts: 932
Joined: Sat Mar 01, 2014 3:15 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by stanley »

Is it possible for you to retrieve serial output before hanging up?
SamyAbi
Posts: 10
Joined: Wed May 19, 2021 2:43 am

Re: Possible reason for ONE+ (H) to stop sending data

Post by SamyAbi »

Hey Stanley,

See attached
Hangup.png
Hangup.png (32.26 KiB) Viewed 2211 times
Post Reply