Waiting for GPS ...

User feedbacks of the latest ESP32 based Freematics ONE+
ehsan.moradi
Posts: 6
Joined: Wed Jan 03, 2018 8:41 am

Waiting for GPS ...

Postby ehsan.moradi » Tue Feb 13, 2018 10:26 am

Hi ...

I uploaded the data_logger firmware v5 to my freematics ONE+. I'm using the standard external GPS module and it is connected.
But, when the sensor wakes from sleeps and goes for the GPS, after "GPS OK", for 300 seconds it shows "Waiting for GPS ..." and it does not start working and reporting location.

What is the problem?

stanley
Site Admin
Posts: 695
Joined: Sat Mar 01, 2014 3:15 am

Re: Waiting for GPS ...

Postby stanley » Tue Feb 13, 2018 8:47 pm

Did you see the blue LED inside the GPS lit up again after waking up?

ehsan.moradi
Posts: 6
Joined: Wed Jan 03, 2018 8:41 am

Re: Waiting for GPS ...

Postby ehsan.moradi » Tue Feb 13, 2018 11:49 pm

No. I never saw a LED in GPS module lighting up!

ehsan.moradi
Posts: 6
Joined: Wed Jan 03, 2018 8:41 am

Re: Waiting for GPS ...

Postby ehsan.moradi » Wed Feb 14, 2018 12:28 pm

Oh, it suddenly started working. I was testing it indoor (close to the window). I'm not sure the problem was reception. but, fortunately I'm receiving location data right now.

stanley
Site Admin
Posts: 695
Joined: Sat Mar 01, 2014 3:15 am

Re: Waiting for GPS ...

Postby stanley » Tue Feb 20, 2018 11:41 am

The GPS stability issue has been addressed and fixed in latest commit. GPS decoding is now done in a separate thread. Please update your library.
https://github.com/stanleyhuangyc/Freem ... 33df1308d1


Return to “Freematics ONE+”

Who is online

Users browsing this forum: No registered users and 1 guest