Page 1 of 1

Cannot compile megalogger sketch?

Posted: Mon Sep 22, 2014 2:07 am
by ncmartz
Freematic Forum members,

Has anyone gotten megalogger software to compile? For the past several days I've tried compiling megalogger software with NO success. I have used Arduino IDE and CodeBlocks compilers software, still having coding issues? I have commented out varies lines of code and still NO success. Downloaded latest megalogger software from GitHub web site still having problems.

Arduino IDE compiler: Have placed all 4 libraries, *.h and *.cpp in the sketch. Also edited and verified config.h for correct configuration of OBD-II (I2C), GPS (serial), motion sensors (I2C), data logging, data streaming (BLE) and data display (SSD1289).

Errors: class LCD_SSD1289 : public UTFT, public LCD_ COMMON
Compiler has generated over 24 errors.

CobeBlocks compiler:

Errors: OBD_PROTOCOL, GET_VOLTAGE and COBDLOGGER setup routines?
Compiler has generated 2 errors and 78 warning.

If anyone has been successful with compiling and uploading megalogger software into Arduino Mega board, would appreciate your assistance in solving this problem? I must be leaving something out, which is not allowing the software to compile. I believe in the KISS principle, "keep it simple stupid", concerning software and hardware development! Nothing fancy, I'm just trying to get the original software to compile, with existing hardware?

Here is my contact info:

Best Regards,
Nathan Martz
United States

Re: Cannot compile megalogger sketch?

Posted: Mon Sep 22, 2014 4:21 pm
by stanley
What's the compiler error message?

Re: Cannot compile megalogger sketch?

Posted: Mon Sep 22, 2014 11:19 pm
by ncmartz
Problem solved had older version of Arduino IDE 1.0.5r2, installed Arduino IDE 1.5.7. Everything working Ok.

Re: Cannot compile megalogger sketch?

Posted: Thu Nov 27, 2014 11:32 pm
by awais
Thanks for your replies my problem is solved. :D :)