Page 1 of 1

Display not working

Posted: Sun Oct 26, 2014 7:40 pm
by rkungl
Hi I purchased the telemetry kit #1 which comes with the oled display 128x64. I am using this with an Arduino Due. I have connected Vcc to 3.3V with no pull up resistors. I have connected sda to (sda 20) and scl to (scl 21).

On your page it says that this display uses sh1106 and I have tried using your lcdhello example code in the microlcd folder and I have uncommented the sh1106 header and commented the ssd1306.

It is not working. I have connected my oscilloscope and I can see that vcc is at 3.3V and there is clean data sending on scl and sda.

I have also tried using u8glib and the adafruit libraries.

Nothing is working.

Re: Display not working

Posted: Thu Oct 30, 2014 9:36 pm
by stanley
The library for OLED (MicroLCD) has not been tested on Arduino DUE.

Re: Display not working

Posted: Sun Nov 02, 2014 10:33 am
by rkungl
I got my arduino nano working by unbricking it since windows 8.1 is now bricking chinese clone devices. I have now run lcdhello on my arduino nano on IDE 1.5.8 and still not a single pixel on the lcd has lit up. It is connected as per the picture on Freematics store telematics Kit#1 as follows (vcc to 3.3v, gnd to gnd, scl to A5, sda to A4).

Still not working, I strongly believe there is a hardware failure of the oled. I just want to get this working. If possible can you send me a new oled and a microsd card since I paid for a working lcd and a microsd card (not a full size sd card).