lto-wrapper failed

Discussion about software developed by Freematics, including Freematics Builder and Freematics Emulator GUI
Post Reply
sbow
Posts: 3
Joined: Fri Sep 13, 2019 12:19 pm

lto-wrapper failed

Post by sbow »

New Freematics-ONE and trying to upload datalogger sketch and I get "lto-wrapper failed" all of my other sketch with other Arduino boards are working fine. Please help :)
////////////////////////////////////////////////////////////////////////////////////////////////////////
lto1.exe: internal compiler error: in lto_output_varpool_node, at lto-cgraph.c:624

Please submit a full bug report,

with preprocessed source if appropriate.

See <http://gcc.gnu.org/bugs.html> for instructions.

lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status

compilation terminated.

c:/program files/windowsapps/arduinollc.arduinoide_1.8.21.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed

collect2.exe: error: ld returned 1 exit status
stanley
Site Admin
Posts: 926
Joined: Sat Mar 01, 2014 3:15 am

Re: lto-wrapper failed

Post by stanley »

Use an older version of Arduino IDE (with older avr-gcc) or use Freematics Builder.
sbow
Posts: 3
Joined: Fri Sep 13, 2019 12:19 pm

Re: lto-wrapper failed

Post by sbow »

Updating Arduino IDE App to 1.8.10 Fixed this problem. Thx.
stanley
Site Admin
Posts: 926
Joined: Sat Mar 01, 2014 3:15 am

Re: lto-wrapper failed

Post by stanley »

This issue has been fixed. Please update Freematics ONE library and your code should compile with latest Arduino IDE.
Post Reply