Freematics ONE issues

Inquiry and support for Freematics products
Felix
Posts: 4
Joined: Thu Oct 26, 2017 9:50 am

Freematics ONE issues

Postby Felix » Thu Oct 26, 2017 11:25 am

Hi I purchased a FreematicsONE.
When it arrived I purchased an SD card (16GB Class10). I plugged the unit into one of our cars. I connected to the bluetooth and fired up the Freematics Hub PE. No data was received by the hub. I unplugged the unit after about 15 minutes and checked the SD card, there was no folder/data on the card.
I tried an various makes and models of car but to no avail.
I have no programming knowledge so am looking for a bit of help or a few pointers to help with this.
thanks in advance
Felix

stanley
Site Admin
Posts: 715
Joined: Sat Mar 01, 2014 3:15 am

Re: Freematics ONE issues

Postby stanley » Thu Oct 26, 2017 7:52 pm

Bluetooth has nothing to do with Freematics Hub which accepts data from devices with WIFI or cellular network. To use Freematics ONE as a data logger, you need to upload "datalogger" sketch to the device by yourself.

Felix
Posts: 4
Joined: Thu Oct 26, 2017 9:50 am

Re: Freematics ONE issues

Postby Felix » Fri Oct 27, 2017 10:13 am

On the website it says
"A data logger sketch is pre-loaded before shipping, your]Freematics ONE will work out-of-box as a vehicle data logger which performs following tasks:
•Connect to the vehicle via OBD-II port
•Connect to the GPS receiver (if available)
•Create a new file on microSD card
•Log OBD-II, GPS, MEMS sensor data to the file (file format)
•Transmit live OBD-II, GPS, MEMS sensor data via USB and BLE.I(am not sure if this means that it will transmit to FreematicsHUB, however it does not state that it does not)

None of which it has done and clearly contradicts your statement.

I have used wireshark and a few other utilities to check and there is no data transfer via Bluetooth.

stanley
Site Admin
Posts: 715
Joined: Sat Mar 01, 2014 3:15 am

Re: Freematics ONE issues

Postby stanley » Fri Oct 27, 2017 3:55 pm

Please let me the serial output you've got so I can give you some advice. Also how did you monitor bluetooth activity by wireshark?
For proper use of Freematics ONE with Freematics Hub software, please read this:
http://blog.freematics.com/2017/setting ... h-arduino/

Felix
Posts: 4
Joined: Thu Oct 26, 2017 9:50 am

Re: Freematics ONE issues

Postby Felix » Tue Nov 07, 2017 1:58 pm

I sort of have it working now, after downloading a whole lot more sketches. I do think that you should maybe change the wording on your website which gives false hopes.

leeodonnell
Posts: 1
Joined: Fri Nov 17, 2017 5:10 am

Re: Freematics ONE issues

Postby leeodonnell » Fri Nov 17, 2017 5:18 am

I've had a similar misunderstanding, apparently.
I plugged the FreematicsONE into the obd port of several vehicles and tried to log data under the expectation that the sketch and all necessary software was preloaded as is claimed on the website. I did not reflash to the FreematicsONE because I believed the software was loaded and QC to insure it was working - so the issue must be the vehicles or SD card I was using.

I think per this discussion on the forum, it should be made more clear when purchasing that the hardware will come blank, and that the sketch must be uploaded, if that is the case.

cpontow
Posts: 6
Joined: Sun Nov 19, 2017 9:06 pm

Re: Freematics ONE issues

Postby cpontow » Tue Dec 12, 2017 6:35 am

Hi Stanley,
I have loaded gpstest-Sketch and test GPS. On Serialmonitor only prints
"Firmware Version 11
Init GPS..."
The blue LED from GPS Receiver flash one more per Sekond and Freematics V4 blue LED flashes more frequently.
No GPS Data in the Serialmonitor!

User avatar
ps-bmw
Posts: 2
Joined: Fri Nov 09, 2018 4:51 am
Location: Munich, Germany

Re: Freematics ONE issues

Postby ps-bmw » Fri Nov 09, 2018 5:36 am

Hi Folks,

same here. Freematics One+ does not work out of the box as a data logger. The website is misleading. I did not know, I have to install additional packages to use it.

Stanley, please fix the website text!


Return to “Freematics Products”

Who is online

Users browsing this forum: Bing [Bot] and 7 guests