Freematics OBD-II UART Adapter V2.1 (for Arduino)

Inquiry and support for Freematics products
BrandonG
Posts: 4
Joined: Mon May 07, 2018 12:29 pm

Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby BrandonG » Mon May 07, 2018 12:36 pm

hello,

I recently purchased a Freematics OBD-II UART Adapter V2.1 (for Arduino). I am using this equipment with an Arduino Mega 2560.
After downloading the library I attempted to run some of the example code. When I run the example code to flash the LED on PIN 13 when the RPM exceeds 3000 RPM, the blue light on the OBD-II UART turns off after a short period of time and the LED on PIN 13 never turns on.

Is this a problem that others have seen before?
Is this something that is easy to fix?

Regards

stanley
Site Admin
Posts: 695
Joined: Sat Mar 01, 2014 3:15 am

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby stanley » Mon May 07, 2018 10:54 pm

How did you connect the adapter to your mega board?

BrandonG
Posts: 4
Joined: Mon May 07, 2018 12:29 pm

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby BrandonG » Thu May 10, 2018 3:29 pm

I the Tx and Rx signals out of the OBD adapter to the Rx and TX of Serial 1 on the Mega 2560. Do I have to use the OBD adapter to power the Mega? I have just been using my laptop.

stanley
Site Admin
Posts: 695
Joined: Sat Mar 01, 2014 3:15 am

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby stanley » Sat May 12, 2018 9:03 pm

Just make sure to connect GND.

BrandonG
Posts: 4
Joined: Mon May 07, 2018 12:29 pm

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby BrandonG » Tue May 15, 2018 8:32 am

I made sure the ground connection was made.
I have isolated the problem to one of two sections of the setup function.
Either obd.begin isn't working as it should or obd.init isnt't working as it should.
The code gets stuck in the while (!obd.init()) loop.
I have tried changing the baud rate with no luck as well as using different vehicles with no luck.
I would like to get this working with a 2008 chevy equinox.
I also tried setting the argument of obd.init(). This didn't work either.

BrandonG
Posts: 4
Joined: Mon May 07, 2018 12:29 pm

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby BrandonG » Mon May 21, 2018 11:31 am

I was able to get everything working. I included the <SoftwareSerial.h> library at the top of the code and everything worked as it should.

jessiehughes
Posts: 1
Joined: Wed Sep 19, 2018 1:33 am
Location: Aten
Contact:

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby jessiehughes » Wed Sep 19, 2018 1:52 am

The Jumper cable is the best for fixing the pin of the Arduino. So you can check the serial activities and LED should be blinking there. After that, you can check the power of the PC's USB port and the serial controller which is the PC sending the Arduino to work to it.

CassieGriffin
Posts: 1
Joined: Sun Sep 23, 2018 7:26 am

Re: Freematics OBD-II UART Adapter V2.1 (for Arduino)

Postby CassieGriffin » Sun Sep 23, 2018 7:34 am

I have found it is working on my sytem. You can check its Menu > Settings > Security.


Return to “Freematics Products”

Who is online

Users browsing this forum: No registered users and 9 guests