OBD-II UART Adapter V2.1 not workimng on Porsche Boxster

Inquiry and support for Freematics products
AnkerBS
Posts: 1
Joined: Wed Aug 08, 2018 4:12 am

OBD-II UART Adapter V2.1 not workimng on Porsche Boxster

Postby AnkerBS » Wed Aug 08, 2018 4:28 am

The adapter will not connect with the Boxster. I have two, a 2002 and a 2004, and it has the same problem with both of them. I have attached a screen shot of running the test application. The strange thing is that I tested it on my Mercedes and then on the Boxsters, and the very first time I tried it it did connect, but after that nothing. What are my options?

Thanks/Anker

stanley
Site Admin
Posts: 695
Joined: Sat Mar 01, 2014 3:15 am

Re: OBD-II UART Adapter V2.1 not workimng on Porsche Boxster

Postby stanley » Sun Aug 12, 2018 9:49 pm

Your cars must use protocol like ISO9141-2 as they are made more than 15 years ago. Technically your can try adjusting timing values.

ATPTH <AA>

Function: set initializing pulse time for (in hex, range of 0~255ms)
Example: ATPTH 19 (set to 25ms)

ATPTA <BB>

Function: set negative pulse duration before first data (in hex, range of 0~255ms)
Example: ATPTA 32 (set to 50ms)

Enclavet
Posts: 1
Joined: Sun Sep 30, 2018 5:41 pm

Re: OBD-II UART Adapter V2.1 not workimng on Porsche Boxster

Postby Enclavet » Sun Sep 30, 2018 5:43 pm

Having same issue on my Porsche 996 turbo 2002.

I tried using the sendCommand to set those timing parameters but never got an Ok from the UART adapter.

Can you show some code to set those parameters?

The below kept on returning ERROR.
sprintf(buffer, "ATPTH 19\r");
delay(10);
if (!sendCommand(buffer, buffer, sizeof(buffer), OBD_TIMEOUT_SHORT) || !strstr(buffer, "OK")) {
continue;
}


Return to “Freematics Products”

Who is online

Users browsing this forum: No registered users and 7 guests