Mega-Kit with Bluetooth - Timeout when upload sketch

Inquiry and support for Freematics products
feelhip
Posts: 1
Joined: Thu Jan 24, 2019 12:52 pm

Mega-Kit with Bluetooth - Timeout when upload sketch

Postby feelhip » Thu Jan 24, 2019 1:24 pm

Hello Support Team,

I recently purchased the Mega-Kit [i]Bluno Mega 2560 – Arduino MEGA 2560 + Bluetooth Low Energy (CC2540)[/i].
When I try to upload the sketch [quote]megaloggerHD[/quote] along with its libraries, I get the error message during the writing process.
[code]Writing | #######avrdude: stk500v2_ReceiveMessage(): timeout[/code]

In general, it looks that when I try to upload heavy sketches and libraries, I get timeouts at some random point during the upload process.

However, when the sketches are lighter, it works better, but I still get timeouts sometimes.

Also, in the Arduino IDE, when I click on [i]Get Board Info[/i], the line with the SN is saying: [quote]SN: Upload any sketch to obtain it[/quote]

When I try to upload the same sketch on another Arduino (ex. Elegoo MEGA 2560 R3 Boar ), it works perfectly well. Also, the SN displays a number when getting board info.

Any idea of what's happening? Is the board deficient?

Thanks

Philippe

stanley
Site Admin
Posts: 710
Joined: Sat Mar 01, 2014 3:15 am

Re: Mega-Kit with Bluetooth - Timeout when upload sketch

Postby stanley » Sat Feb 16, 2019 10:22 pm

Have you tried uploading with BLE dongle?


Return to “Freematics Products”

Who is online

Users browsing this forum: Bing [Bot] and 4 guests