Kia Picanto Issue

Inquiry and support for Freematics products
Post Reply
Diego
Posts: 2
Joined: Sun Jun 02, 2019 6:54 am

Kia Picanto Issue

Post by Diego »

Hi Team,

Have searched the forum to no avail - hopefully someone has encountered and solved this.

When connecting a MEGALOGGER HD to a 2018 KIA PICANTO the unit works as described but the vehicle goes into melt down displaying a fault with the Traction Control and the EAB (Braking) System.

Have tried the unit in two other vehicles including a 2015 KIA RIO and everything works as it should

:arrow: I have uploaded the latest SKETCH - No change
:arrow: Changed the OBD Baud Rate (Serial 1) to 9600 - No Change
:arrow: Turned off GPS - No Change (other than no Red Cross next to GPS)
:arrow: Changed OBD PROTOCOL from AUTO to PROTO_TSO_9141_2 - Both Errors disappeared from the vehicle and some tables of hex code appeared on the Arduino screen but it failed to move to display mode.

MEMS also has a Red Cross against it

Any thoughts ?

stanley
Site Admin
Posts: 786
Joined: Sat Mar 01, 2014 3:15 am

Re: Kia Picanto Issue

Post by stanley »

Some cars, though they are on CAN bus, use OBD pins for K-line or ISO9141 for non-standard use and this could cause such issue.
Do you have a OBD-II UART Adapter V2 or V1? MEMS is only available with V2.

Diego
Posts: 2
Joined: Sun Jun 02, 2019 6:54 am

Re: Kia Picanto Issue

Post by Diego »

ISO9141 for non-standard use and this could cause such issue. -- Is there a fix or are they just incompatible items?

Do you have an OBD-II UART Adapter V2 or V1? -- No indication of version on the device, acquired as part of Freematics Mega Kit (Arduino Mega based) KIT-3 on 22/05/2019

Post Reply